Prerequisites for my workshop/ session on Creating your own SharePoint 2013 VM, Live!

I am truly excited & honored to be speaking at the SharePoint Saturday events. As the name suggests, these are whole day events held on Saturdays and are free for you to attend. There are multiple sessions being held at a time with a whole lot of SharePoint awesomeness going on throughout the day. The sessions are targeted at audience ranging from IT Pros and Developers to End users and vary in complexity from simple to advance level. You can view the session schedule and a list of speakers for your city by browsing to the SharePoint Saturday events site here

The topic of my session at these events is: “Workshop: Create your own SharePoint 2013 dev./ test VM, Live!“. As the session title mentions, I demonstrate how to create a SharePoint 2013 dev./ test VM from scratch using a single click PowerShell script that employs industry defined best practices to not only install SharePoint but also prepare the server for the installation. The session also encourages you to create your own VM alongside if you’d like to. You will need the following tools and software to be able to do so:

  1. Downloads:
    1. VMWare Player 6.0 (free): This is the virtualization tool that we will use for our demo. You can download the free VMWare Player from this link. This is the virtualization tool I will be using for the demo but please feel free to use another tool of your choice (VMWare Workstation/ Hyper-V/ Virtual Box etc.).
    2. ISO of Win Server 2012 R2 Eval: http://technet.microsoft.com/en-us/evalcenter/dn205286.aspx OR a licensed version of the OS that you might have access to.  Note that even though the software selection drop down on the download page mentions the Windows Server Datacenter edition, it really has other editions bundled into it as well. We will be able to select the edition we want to use at the time of the installation.
    3. SQL Server 2014 Eval ISO available herehttp://technet.microsoft.com/en-us/evalcenter/dn205290.aspx  OR a licensed version of SQL that you might have access to (either SQL Server 2012 SP1 OR SQL Server 2014 will be fine – though we will be using SQL Server 2014 for the live demo)
    4. The software and script package through my drive here: This package contains:
      1. Additional software necessary for the installation including the following:
        1. SharePoint Server 2013 prerequisites
        2. SharePoint Server 2013 with SP1: Unfortunately there’s no other link for the trial version of SharePoint 2013 with SP1 that I can share with you. You can also download the installation media using your subscription benefits from the subscriber downloads site using your VLSC, MSDN and MPN benefits and replace the file in my downloads with your own copy.
        3. SharePoint 2013 November 2014 CU (Optional)
      2. The scripts package that we will use to carry out the installations
    5. Finally, as mentioned above, I would like to show you how to create a Windows Server 2012 R2 VM during the session. However an hour will not be sufficient for us to go through the complete Windows installation. As a bonus therefore, I have also uploaded an image of the Windows Server 2012 R2 Trial VM that you can download here. The files are roughly 4 GB in size. Please ensure that you download all the files and extract the zip archive. Once extracted, you will notice 8 files totaling around 11.2 GB in size.  To download the VM files, you can go with either of the following options:
      1. Add the shared Google drive folder to your Google Drive through the “Add to Drive” button on the top right corner of the page and then use the Google Drive Desktop Client to sync the files to your local computer (recommended) OR
      2. Download the files directly by using the browser “Save target as…” functionality (less recommended)
    6. Please note that while I’ve mentioned eval editions of various software above, you are encouraged to use your own licensed version of the software if you have access to them.
  2. Other host requirements: In addition to the above downloads, you will need to ensure the following on/ for your host machine:
    1. You are able to allocate at least 12 Gb and a recommended of 16 GB of memory to the guest VM that we will be creating. Ideally, that would mean you have at least 16 to 20 GB RAM available on your host. You have at least 50 GB of free space on the disk that will contain the VM (the downloaded VM files included)
    2. Your host should be running on Windows 7 or above (64 bit) and it supports virtualization

Finally, please note that even though we will be going through a SharePoint 2013 installation during our session, the steps will hold equally true for a SharePoint 2010 installation as well.

That’s pretty much it. Please feel free to reach out to me via the comments below or through my twitter handle: @mahajang if I can be of further help. I will also be available after the session to answer your questions and in case you’d like help downloading the files. I’ll look forward to seeing you at the event and I hope you are as excited to be there as I am!

Advertisements
This entry was posted in SharePoint 2010, SharePoint 2013, Speaking, Tools, Virtual Machine and tagged , , , . Bookmark the permalink.

32 Responses to Prerequisites for my workshop/ session on Creating your own SharePoint 2013 VM, Live!

  1. nick says:

    Hi,
    is somewhere you speaking?
    or a guide how to build up our own sharepoint using your scripts?

  2. nick says:

    Hi, had some problems with the version of vm to the environment i want to use it, so i convert it but it had this problem http://www.tbngconsulting.com/blog/bid/385396/9-steps-to-correcting-a-Windows-Server-2012-0xc00002e2-Error so i unistall active directory,till step 2 but i can not login as domain admin, only as local admin.is the password working?
    Do u have an idea? should i clean the DNS?

    • nick says:

      now i can not login as local admin!!!!

      • Hey Nick,
        Sorry you are having problems. Is this the Windows Server VM accompanying this blog that you are talking about or are you talking about the pre-built SharePoint server VM uploaded through my blog? Also, did you make other changes to it “before” you received BSOD? If not, the BSOD would typically be because of your host configuration or because all the files for the VM did not get downloaded properly.
        Thanks!

      • nick says:

        It was this http://goo.gl/Q0NS71 one. Anyway i am builting my own from scratch, maybe i will try to use your scripts.Thanks anyway.

      • Yes, that is a good link and should’ve worked without any issues if the files got correctly downloaded. Sure, please let me know if you run into any issues with the scripts or have any related questions that I can help with.
        Thanks!
        Gaurav

  3. Ernie says:

    Hi Gaurav – fantastic script, I’m getting so close to finishing! I’ve fixed a few things, but this one has me. I’m at the SQL install, and the error is ‘the system cannot find the file specified’. I’m assuming this is the ISO, but I see the drive mounted, and when I look inside I see the setup.exe. I also see a screen pop-up with red text, so I put a trap in InstallSQL.ps1, and it’s complaining about ‘param’. Any ideas what to change? THANKS! – Ernie

    • Hi Ernie! Thank for your kind words and very sorry I am just getting to your comment. That is truly an odd message. I can recommend the following:
      1. Could you please check if you have modified any of the parameters being passed to the script, including the credentials?
      2. Could you please confirm that the path for the config file for the respective sql version you are installing is correct ?
      3. There should be a sql error log file created at the path I’ve mentioned in my custom error message. Could you please review that file for errors or send it to me for a review?
      4. Finally, if the above look good to you, could you please remove all media from the folders, zip the entire package and share it with me?
      Thanks and I’ll await your response

      • Ernie says:

        Thank you for helping Gaurav!!! I modified $ParentDir = $PsScriptRoot because .net 3.5 did not install. It installed correctly after changing the variable, but then SQL failed. I’ll go back and install .net 3.5 by hand and continue with step 7 and let you know.

  4. Ernie says:

    (failed to tell you in the 9:48 am reply that I restored the correct variable and tried again).
    New info – Installed .net 3.5, and restarted script @ “InstallSQL”, same fail.
    Here are my details from log:
    10:29:53 AM : Opening SQL ports.
    Mount-DiskImage : The system cannot find the path specified.
    At C:\Scripts\Main.ps1:362 char:19
    + $SQLImg = Mount-DiskImage -ImagePath $SQLISO -PassThru
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : ObjectNotFound:
    (MSFT_DiskImage:ROOT/Microsoft/…/MSFT_DiskImage)
    [Mount-DiskImage], Ci mException
    + FullyQualifiedErrorId : HRESULT 0x80070003,Mount-DiskImage
    10:29:56 AM :
    The following error occured while executing the script: Cannot validate argument
    on parameter ‘DiskImage’. The argument is null. Provide a valid value for the argument,
    and then try running the command again.

    • Thanks for the updates Erin. As requested earlier, will it be possible for you to zip the scripts (without the media) and share them with me? I can also DM you my email id on Twitter if you’d like to email them to me. Thanks

  5. fjulie128 says:

    Hi Gaurav,
    Thank you so much for your VM it is relly so great ! unfortunately, i need some help for testing the creation from scratch, i yould like to learn how to do this. the link to slideshare doens’t work (the document have been delete) could you importe it once again ? (sorry for my english, i’m from France)

  6. fjulie128 says:

    Hey Gaurav,
    Could you help me for that problem ?
    i put the Scripts directory and SW directory in C:\ and run the RunMain.bat, i test to run directly the Main.ps1 but i always have this error :
    PS C:\Scripts> C:\Scripts\Main.ps1
    Transcript started, output file is C:\\SPSingleClickInstallerLog-2015-08-29_10-26.txt
    10:26:13 AM : Script started
    10:26:13 AM : Backing up the local UAC and error action settings
    10:26:14 AM : UAC is now turned off but it will take effect after the next restart
    10:26:14 AM : Loading functions
    10:26:14 AM : Step 1: The script will initialize the disk drives and install framework 3.5
    10:26:14 AM : Initializing the disks
    10:26:15 AM : Expanding the pre-requisites zip file
    10:26:15 AM : The following error occured while executing the script: You cannot call a method on a null-valued expression.
    10:26:15 AM : Step 9: Performing cleanup
    10:26:15 AM : Restoring the local UAC and DefaultErrorAction settings
    10:26:16 AM : Starting the audio service for script completion notification
    10:26:21 AM : The script has completed execution. The transcript file is created at:C:\\SPSingleClickInstallerLog-2015-08-29_10-26.txt
    Please review the output above and press any key to continue…:

    • fjulie128 says:

      here is the log file :
      **********************
      Windows PowerShell transcript start
      Start time: 20150829103740
      Username: WIN-TEDQCP884BM\Administrator
      RunAs User: WIN-TEDQCP884BM\Administrator
      Machine: WIN-TEDQCP884BM (Microsoft Windows NT 6.3.9600.0)
      Host Application: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -NoExit C:\Scripts\\Main.ps1
      Process ID: 2200
      **********************
      Transcript started, output file is C:\\SPSingleClickInstallerLog-2015-08-29_10-37.txt

      **********************
      Windows PowerShell transcript end
      End time: 20150829104013
      **********************

      • fjulie128 says:

        Hy Gaurav,
        It’s fine, i complete the installation from your windows 2012 VM and your scripts. I comment the code block of extracting preriquisite and extract it manualy to skip the problem (i will pay attention for it later). My goals are, refresh and update my skills in system and database administration and learn from scratch about sharepoint site administration. Now, i have to learn from all scripts i’d use to automate the installation of sharepoint. thank you Gaurav
        Your blog is very helpful
        Julie

      • Hi Julie
        I am extremely sorry I wasn’t able to reply to you in time. But I am glad you were able to resolve the issue on your own! Kudos! Please do let me know if i can be of further help and I will try to reply back sooner this time! 🙂
        Thank you!
        Gaurav

  7. fjulie128 says:

    Hi Gaurav,
    Don’t be sorry, if i couldn’t found the solution by myself, i’ll wait patiently for your help. however, if you have an idea about this code block(#Expand the prerequisites if they are part of zip a file) and the associated parameter, i’m interesting 🙂

    • Hi Julie
      Yes, I can surely elaborate on that. If you look at the SW folder in the script package mentioned in Step 1. D. above (and available at http://goo.gl/MDxTyB), you will notice that it has a zip file called “SharePoint 2013 Prerequisites.zip”. The script expects the zip file to be present if the value of the $SPPrereqsFrameworkZipFile variable defined in “General Variables” region of the script is not set to “” (an empty string). Looking at the error, my initial “guess” is that it was not able to locate the zip file or correctly extract it for some reason. I may be wrong though and will let you verify my assumption.
      Thank you!

  8. Mark says:

    New to this and would love to try the script method. where do I place everything and run the scripts from?

    • Hey Mark
      Very sorry for the late response. You will want to place the scripts on a folder in your Windows 2012 R2 server. Please do let me know if i can be of further help. I promise to respond back sooner this time 🙂
      Cheers
      Gaurav

  9. macgilemac says:

    Hi Gauray Mahaja,

    Thank’s for all about this 🙂

    I have an error happens when the script in step 4:
    4:47:21 p.m.: Step 4: The script will create a new forest with the “SPSat.dev” domain name and reboot.
    4:47:21 p.m.: The following error occurred while executing the script: Failed to check prerequisites for promoting the domain controller. The argument “CreateDNSDelegation” specified was not recognized.

    How can I resolve this please ?
    Best Regards

    macgile

  10. macgilemac says:

    Hi Gauray Mahaja,

    Thanks for reply 🙂
    I use windows server 2012 R2, SQL server 2014 and SharePoint 2013.
    Thanks!

    Best regards

    Macgile

    • That is truly very strange. I have personally never encountered this error and was unable to look up any information online either. I will keep researching it but have a few questions for you:
      1. Did you make any updates to the server before running the script?
      2. Did you make any changes to the script itself? If so, will it be possible for you to share the modified script by uploading it to a shared drive?
      Thanks!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s